Life is Feudal MMO review

Discussion of interesting applications and computer games available on the market.
User avatar
Posts: 2543
Joined: Sat Mar 01, 2008 11:34 pm
Realm: Europe
Account: 3ICE
Clan: 3ICE
Location: Hungary

Life is Feudal MMO review

Unread post by 3ICE »

Launcher wrong language (NOT English even though my region, OS and locale are all English... What else do you need? A move to America?) Email address required even for demo island. (Even RuneScape waits until after tutorial is complete.) Edit: Completed the tutorial, for the permanent lucky necklace. Took 10+ hours because I got stuck several times, had to delete + recreate my character to fix continuity errors.
Fell into a pit right in town. The /unstuck command ever so helpfully moved me 1 mm to the side after a pointlessly long cast time. Ended up having to teleport home. But I had no home yet! Back to the shore, repeat the 300m walk.
Also experienced untold number of bugs and suffered through clunky gameplay mechanics.
Misinformation, lag, spam, trash piling up mile high on the streets, unfair deaths, everything is too slow.
Clean chicken coop quest step → hundreds of dropped items all over town, all full of "fertilizer" (chicken excrement)
Too many players not enough resets → the clay pit you're supposed to dig in reaches the bottom of the world. Also it ran out of clay so cannot progress.
Gravedigger is underground, only his head sticks out slightly, if the camera is angled just high. Hundreds of players completing "spill dirt on ground" quest step.
Permission errors:
Trees fail to chop - no permission anywhere in these lands — I can chop trees but not touch the spawned logs "no right to perform the ability on those lands…" → I have to walk well outside protected zone to gather wood. Swarms of players doing the same. Lead to island-wide deforestation. No new trees are allowed to grow, only bushes and still get chopped down. Locusts!
Picked up a log, can never put it back down. Because apparently "something is blocking that spot" -- there's literally nothing for miles… Stuck-with-log-on-back-forever--in-tutorial
"Failed to find any tracks" Life is Feudal MMO: fail to find tracks for half an hour
Cannot build shelter for children "behind town" → had to walk all the way to opposite shore to complete quest step.
I have no right to deconstruct my buildings? I placed them, let me delete them!
If the right tool is not equipped, the respective UI option is simply non-reactive. How about a tooltip or error message?
Some buildings can be built, others, not. In the very same category… What is the difference? Never figured it out. (Terrain is leveled, materials are at hand, Hammer is equipped; what else do you need from me!?)
Fireleaf can be stolen over and over from the chest. But once the quest is one step ahead, then never again. If I didn't use the drop trick and stock up on it I'd have missed out on several NPCs optional dialogue. And in fact, I did; after I died and lost everything, no more fireleaf for the final two quests.
I see a weird green graphical anomaly in the distance… I walk closer and see it is all around the blacksmith. Whose hammering is super loud and annoying! Long while trying to read quest text / craft metal items with that noise.
Baromsag is lost on death. Cannot reobtain.
There is a suicide ability with a cryptic name. I, uh, tried it out. Yeah, it killed me.
And here's the kicker; dying inside my house spawns no corpse. All my possessions imploded. Lost everything.
Cannot craft shoes even though I have sewing kit? Turns out I had to right click the sewing kit to open the exact same menu but without all buttons disabled. Except for a long time the only option on it was "drop".
As soon as you fix the -10% speed debuff (no shoes) the game starts to rubberband. Speedhack countermeasures hurting legitimate players, I see.
Uninstall leaves half a gigabyte of junk on my PC. 800+ files, 60+ folders. Worst is the following folder:
…\SteamApps\common\Life is Feudal MMO\game\eu\art\Textures\TextureLib\
The first time I uninstalled it didn't even uninstall the launcher properly. So it ended up redownloading itself overnight. (Yes, I made sure the game was closed before uninstalling… Still left 800+ junk files behind.)

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests